How to fix split table in MemoQ RTF export files
Auteur du fil: Samuel Murray

Samuel Murray  Identity Verified
Pays-Bas
Local time: 06:40
Membre (2006)
anglais vers afrikaans
+ ...
Apr 16

Hello everyone

I sometimes get MemoQ-style RTF files (you know, with the columns) to translate and/or edit. I don't work directly in these RTF files, but rather copy/paste the content to another file and work on it in that other file (in my own CAT tool). Then, when I'm done, I copy/paste the target column's text back into the MemoQ RTF file. (I'm pasting text, not a column, into the appropriate column)

Sometimes, when I do that, the table splits. It splits above the
... See more
Hello everyone

I sometimes get MemoQ-style RTF files (you know, with the columns) to translate and/or edit. I don't work directly in these RTF files, but rather copy/paste the content to another file and work on it in that other file (in my own CAT tool). Then, when I'm done, I copy/paste the target column's text back into the MemoQ RTF file. (I'm pasting text, not a column, into the appropriate column)

Sometimes, when I do that, the table splits. It splits above the uppermost cell that I'm pasting in. The split table still looks like one table, but you can see it's two tables if you hover over it and look for the "+" icon in the top left corner.

Usually, in MS Word, you can join tables by simply removing all line breaks between the two tables. However, this does not work for the MemoQ RTF files. No matter what I try, the split table remains two tables.

I know that some clients have trouble importing RTF files in which the table has been split.

Does anyone know how to solve this table splitting problem? How does one merge a table in a MemoQ RTF file that got split and refuses to merge again if one simply ensures that there are no line breaks between the two tables?

Thanks
Samuel
Collapse


 

Rafa Gómez  Identity Verified
Espagne
Local time: 06:40
Membre (2009)
anglais vers espagnol
Workaround - Convert to DOCX and translate with Okapi Rainbow + OmegaT Apr 17

Hi Samuel,

I'd personally use memoQ, which is my preferred CAT tool, but I totally understand if that's not your cup of tea.

Assuming that you're using OmegaT, you can follow this workaround:

  • Open the RTF file and copy the source column to the target column.

    copy-source-to-target
  • Hide all text except the target column.

    RTF-hidden
  • Save the file as DOCX.
  • Create an OmegaT project with Okapi Rainbow.

    okapi-kit
  • After completing the translation in OmegaT, generate the target document and then use the Translation Kit Post-Processing option in Okapi Rainbow.
  • Open the converted DOCX file (in a project subfolder called done), unhide all text and convert the file back to RTF.

Just made a couple of tests, and it seems to work fine. As long as the header and table structure remain intact, this round-trip format conversion (RTF to DOCX and vice versa) should be safe.

Notes:

  • By default, OmegaT translates all hidden text in DOCX files, and that's why you need to prepare the project with Okapi Rainbow. You could also use styles to exclude the non-translatable text, instead of hiding it.

    okapi-hidden
  • To avoid translating the document properties in OmegaT, create a new filter in Okapi Rainbow and clear the option Translate Document Properties.

    properties


 

Samuel Murray  Identity Verified
Pays-Bas
Local time: 06:40
Membre (2006)
anglais vers afrikaans
+ ...
AUTEUR DU FIL
@Rafa Apr 17

Rafa Gómez wrote:
  • Open the RTF file and copy the source column to the target column.


  • And that is where it breaks, because as soon as one copies the source text to the target column, the table splits. It doesn't always do that, but when it does, it does, and then any workaround that relies on first copying the source text to the target column is no solution.

    My current workaround is to split the table myself at row 3, then add several extra rows, then merge the cells in one row, and then manually copying the header's content into the newly inserted cells, and then finally deleting the original header.

    [Edited at 2019-04-17 16:06 GMT]


     

    Rafa Gómez  Identity Verified
    Espagne
    Local time: 06:40
    Membre (2009)
    anglais vers espagnol
    Not sure then Apr 17

    Hmmm… I can't reproduce the issue (Word for Office 365 on Windows 10):

    https://imgur.com/a/FSmkWxx

    Sorry, wish I could be of more help.


     

    Stepan Konev  Identity Verified
    Russie
    Local time: 07:40
    anglais vers russe
    Ctrl + drag&drop Apr 19

    Another way: Select source -> Press and hold Ctrl -> Drag and drop it against the first row in target.

     


    To report site rules violations or get help, contact a site moderator:


    You can also contact site staff by submitting a support request »

    How to fix split table in MemoQ RTF export files

    Advanced search






    SDL Trados Studio 2019 Freelance
    The leading translation software used by over 250,000 translators.

    SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features.

    More info »
    PerfectIt consistency checker
    Faster Checking, Greater Accuracy

    PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

    More info »



    Forums
    • All of ProZ.com
    • Recherche par terme
    • Travaux
    • Forums
    • Multiple search